How to Upgrade to 3.0.1 and Unlock iPhone 3g with baseband 2.30.03 & bootloader 5.09, 6.02, 6.04

First you will need cydia to download fuzzyband. When fuzzyband detects your modem version it will ask you to uprade. click on upgrade:

311986

* your screen will say OS 2.2.1

Now start up iTunes and update to the latest 3.0.1

updateupdate2

Download redsn0w here

Download the 3.0 ipsw file here

Extract the redsn0w zip file and start redsn0w.exe
Browse for the ipsw file and follow the directions.

After jailbreaking the phone, you need to unlock it with ultrasn0w.

Download ultrasn0w
Goto cydia -> manage -> sources -> edit -> add
enter http://repo666.ultrasn0w.com
16527
return to cydia, hit done and select the new repo you just added.

Install ultrasn0w and follow instructions.
16532

You are now unlocked!

7 thoughts on “How to Upgrade to 3.0.1 and Unlock iPhone 3g with baseband 2.30.03 & bootloader 5.09, 6.02, 6.04”

  1. hi,

    so is it possible to unlock your if phone if you have :

    iphone 3g
    OS 3.1
    and bootloader 6.02 ?

    thanks

  2. I try searching fuzzyband downgrader version 3.1 b1 using Cydia but not found. i just found fuzzyband version 3.1gm. Can u please help me give me the direct link to download…or advice me

    tq

  3. i tried this method but it is not working, fuzzyband only support BL 5.8 and it is not working for BL < 5.8
    unfortunately i upgrade my iphone from 3.0 to 3.1.2 by Itunes . I downgraded it back to 3.0 successfully but now stuck with unlocking as 3.1.2 had upgrade my BL and BB

Comments are closed.